1
$\begingroup$

I find the animations initiated by the run command are so fast that visually I cannot follow them in any detail. I have been unable to find any setting in the program to slow them down. Likewise I cannot find any comments on the internet or in forums that say how to slow down visuals.

I am using GMAT 2019a on linux.

Anyone with any insights, please drop a response.

thanks, tom kosvic

$\endgroup$
2
$\begingroup$

In the "Output" section of the "Resources" tab, right-click and add "OpenFrames Interface". After the mission is completed, you'll be able to play back the mission at a reasonable speed.

Also, I would recommend you to update to R2020a: I think that everything is compatible with R2019a.

$\endgroup$
2
  • $\begingroup$ I have no option in 2019a to add OpenFramesInterface under Resources/Output. The "add" options are: ReportFile, XYPlot, Orbitview, Ephemeris, GroundTrack, and Dynamic DataDisplay. This is after running MarsBPlane tutorial script. There is no OpenFrames Interface addition listed. Any further suggestions? Perhaps R2019a does not have this option and it was added in 2020a. I will look into this. $\endgroup$ – tckosvic Mar 26 at 16:20
  • $\begingroup$ Oh right, it might have been added in 2020a. If so, I don't know how to change the animation speed in GMAT 2019a. $\endgroup$ – ChrisR Mar 26 at 16:40
2
$\begingroup$

At the top of the GMAT window there are animation controls. The buttons are play, stop, faster, and slower. They are the red/blue buttons. They only light up if the appropriate plot window is active (e.g., ground track plot or orbit view plot). I highlighted them in the image below. enter image description here

As Chris mentioned, there is a new plotting interface available in GMAT 2020: Open Frames Interfaces. They are basically better in every way so I recommend upgrading to 2020 :)

If you do use OpenFrames, you can scrub through time with a slider and also adjust the animation speed, all in the window itself.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.