1
$\begingroup$

I have been dealing for a while on a report which is generated by STK. It contains basically time, azimuth, elevation and range data. Besides those data I need to also generate the theta and phi angles. I could be able to done those vectors and angles. They are visible from the report generation (new report - preferences).

All my data can be generated without a problem but, my question is more about on the times..

I have five different ground stations and one satellite. Satellite do accesses with all ground stations. Normally azimuth, elevation and range data can be visible when the access is available. But my angle values are seeing all the time whether an access done or not. With this configuration AER and angle data have different times. AER has only access times but angles are have the whole scenario time. I just want to have only 1 time constraint which is calculated by access or whenever AER is measured.

Is it possible to edit this obstacle from anywhere inside the STK itself? Or I am wanting something totally non-doable..

Thanks in advance!

$\endgroup$
4
  • $\begingroup$ Can you tell us more about theta and phi? Are those angles you created using Analysis Workbench within STK? Or are they one of the pre-computed angles in STK? If so can you tell us what data provider (or report) you found them under? $\endgroup$ – Carlos N May 24 at 22:16
  • $\begingroup$ @CarlosN, I was able to solve this issue. All the angles I have used there created on my own from, as you mentioned, Analysis Workbench. I do not know exactly right now what I have done, but it was something like configuring the access interval options from the report output generation page (specifying the time properties by custom interval list). $\endgroup$ – Onur Gürdoğan May 25 at 9:51
  • 1
    $\begingroup$ It's always okay to answer your own question in Stack Exchange, especially considering that you are in a good position to judge if the problem has been solved or not. You can also post a "partial answer" or "supplementary answer" if you feel your solution is incomplete. In order to encourage you to do so or to potentially attract more answers I'll start a bounty. $\endgroup$ – uhoh Jun 3 at 23:05
  • $\begingroup$ I will try to write a proper answer about "what I have done it so far". $\endgroup$ – Onur Gürdoğan Jun 4 at 8:20
1
+100
$\begingroup$

I was trying to prepare an report for the electric thrust LEOP by STK. This report was going to include satellite x, y , z axes + some other satellite related angles (which were all created by myself using vectors) and finally access times with respect to the five different ground stations separated all around the world to satisfy the LEOP requirements.

Even if I created a customize report for all data mentioned above, it was failing. Since I had five different ground stations, satellite was going to have different access times and durations with those stations. But all the other non-time related data was going to produced every time (user defined time steps).

So, I was wanting to see all of my satellite related data only if the access is occurred. In a default option, STK is going to show your satellite related data in every 1 second (if it is your default time step) even if there is no ground station access. So, due to that issue, some time constraint mismatching and it was very crucial for us.

Day Month Year Hour Minute Second Satellite X Satellite Y Satellite Z Satellite Theta Satellite Phi Some other data will go through to column 66 and repeated for every 5 different ground stations

At the first time I was trying to find a solution under the access section, but unfortunately I was not able to find anything.


After a while, while I was playing around on the Report & Graph Manager page, I found something. It was Specify Time Properties just under the Time Properties option. After selecting the Specify Time Properties then you should select the Custom Interval List from the drop down menu which is Select Type. Then you should select an interval from the Select Interval List. After that a new page will pop-up and under the Installed Components you should be seeing the AvailabilityIntervals time constraint option. After selecting this option my problem solved and I saw my data (even if you have non-time related satellite data) only at the satellite-ground station access times.


Note: Sorry for not sharing an image, because my STK is operating inside a workstation which has no internet connection at all.

$\endgroup$
1
  • $\begingroup$ It's always okay to accept your own answer also. I usually wait a few days though, posting your answer puts your question back into the active queue and more folks may read it and may add further answers. I'll award the bounty to this answer because the OP (in this case you) has determined that this solves the problem. $\endgroup$ – uhoh Jun 8 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.